React Native Do With Firebase

React Native Do With Firebase 1.2.4

A fascinating React Native starter kit with flat UI design, MobX, NativeBase components and integrated with Firebase for your iOS and Android application.
Inspired by Invision's UI Kit, DO

Note: This product is available with Expo Client.
We don't recommend to upgrade Xcode to version 10 for running the apps on the local machine as React Native doesn't have support for it at the moment.
.


Development Environment
Demo Available

All the screens you'd want!

Fully customizable, ready-to-use screens with flat UI design that adds an aesthetic touch to the app

  • ● Login
  • ● Sign Up
  • ● Forgot Password
  • ● Walkthrough
  • ● Drawer
  • ● Home
  • ● Overview
  • ● Groups
  • ● Lists
  • ● Settings
  • ● Profile
  • ● Calendar
  • ● Timeline
  • ● Create New
  • ● Splashscreen

Note

The package includes both the UI theme and its Firebase version.

React Native Do With Firebase

Technologies Used

  • Firebase
  • NativeBase
  • React Navigation
  • ESLint
  • Flow
  • Expo
  • MobX

Features

React Native Do With Firebase

Perfectly native look and feel with React Native

Eye soothing UI with awesomely smooth UX!

React Native Do With Firebase

Package

React Native Do With Firebase

  • ● @expo/vector-icons: 6.3.1
  • ● autobind-decorator: 1.4.0
  • ● colors: 1.0.3
  • expo: ^29.0.0
  • ● firebase: 4.12.1
  • ● jest-junit-reporter: 1.1.0
  • ● lodash: 4.17.4
  • ● mobx: 3.1.9
  • ● mobx-react: 4.1.8
  • ● moment: 2.18.1
  • native-base: 2.4.1
  • ● react: 16.3.1
  • react-native: https://github.com/expo/react-native/archive/sdk-29.0.0.tar.gz
  • ● react-native-card-carousel: git+https://github.com/wcandillon/react-native-card-carousel#6dc8048
  • ● react-native-datepicker: 1.6.0
  • ● react-navigation: ^2.9.3
  • ● throttle-debounce: 1.0.1
  • ● babel-eslint: ^8.2.1
  • eslint: ^4.9.0
  • ● eslint-config-airbnb: ^16.1.0
  • ● eslint-plugin-flowtype: ^2.41.0
  • ● eslint-plugin-import: ^2.7.0
  • ● eslint-plugin-jsx-a11y: ^6.0.2
  • ● eslint-plugin-react: ^7.4.0
  • ● eslint-plugin-react-native: ^3.2.1
  • ● exp: 55.0.5
  • ● expo-cli: ^1.1.0-beta.4
  • ● firebase-bolt: 0.8.2
  • ● firebase-bolt-transpiler: git+https://github.com/wcandillon/firebase-bolt-transpiler#e4172ab14a43a3dd6f29711582a9780d91e93238
  • ● firebase-tools: 3.9.2
  • ● flow-bin: 0.63.1
  • ● flow-result-checker: ^0.3.0
  • ● jest-expo: ^29.0.0
  • ● react-native-scripts: 1.11.1
  • ● react-test-renderer: 16.0.0-alpha.12

React Native Do

  • ● @expo/vector-icons: 6.3.1
  • ● color: 1.0.3
  • expo: ^30.0.0
  • ● jest-junit-reporter: ^1.1.0
  • ● lodash: ^4.17.4
  • ● moment: ^2.18.1
  • native-base: 2.4.1
  • ● react: 16.3.1
  • react-native: https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz
  • ● react-native-card-carousel: git+https://github.com/wcandillon/react-native-card-carousel#6dc8048
  • ● react-native-iphone-x-helper: ^1.0.3
  • ● react-navigation: ^2.13.0
  • ● babel-eslint: ^8.2.1
  • eslint: ^4.9.0
  • ● eslint-config-airbnb: ^16.1.0
  • ● eslint-plugin-flowtype: ^2.41.0
  • ● eslint-plugin-import: ^2.7.0
  • ● eslint-plugin-jsx-a11y: ^6.0.2
  • ● eslint-plugin-react: ^7.4.0
  • ● eslint-plugin-react-native: ^3.2.1
  • ● exp: 55.0.5
  • ● expo-cli: 2.2.0
  • ● flow-bin: 0.63.1
  • ● flow-result-checker: ^0.3.0
  • ● jest-expo: ^30.0.0
  • ● react-native-scripts: 1.11.1
  • ● react-test-renderer: 16.0.0-alpha.12

BROUGHT TO YOU BY

Start building your app today!

Get Started