GIF React Native E-Commerce Starter

React Native E-Commerce Starter 8.0.0

A well structured React Native starter project to build your iOS and Android e-commerce app


Development Environment
Demo Available

Do it your way!

Fully customizable pages along-with a rich collection of UI elements specifically for an ideal e-commerce app

  • ● Login / Sign Up
  • ● Track Order
  • ● Notifications
  • ● Drawer menu
  • ● My Orders
  • ● Social Buttons
  • ● Wishlist
  • ● Shopping Cart
  • ● Payment (with options)
  • ● Credit card form
  • ● Product List View
  • ● Product Grid View
  • ● User Profile
  • ● Checkout flow
  • ● Shipping (Add address)

React Native E-Commerce Starter

NOTE

This starter kit is only a UI theme and it doesn't include any back-end code, neither it is wired up with any API calls.

Features

  • Power-packed with Redux, NativeBase and React Navigation
  • Integrated with CRNA and Expo
  • Fascinated blend of React Native and ES6
  • Single JavaScript code base for iOS & Android
  • Enormous set of UI Elements
  • Highly customizable widgets
  • Readily available screens
  • Easy Routing, just like web
React Native E-Commerce Starter
React Native E-Commerce Starter

Quality Code

  • ESlint for code quality
  • Husky to prevent bad commit, push
  • Prettier for pretty, formatted JavaScript code

Perfectly native look and feel with React Native

Eye soothing UI with awesomely smooth UX!

React Native E-Commerce Starter

Package

React Native E-Commerce Starter

  • ● color: 1.0.3
  • expo: 21.0.2
  • ● lodash: ^4.13.1
  • ● moment: ^2.13.0
  • native-base: 2.3.1
  • ● react: 16.0.0-alpha.12
  • react-native: 0.48.4
  • ● react-native-easy-grid: 0.1.7
  • ● react-navigation: 1.0.0-beta.11
  • ● react-redux: 5.0.5
  • redux: 3.7.2
  • ● redux-form: 7.0.3
  • ● redux-persist: 4.10.0
  • ● redux-thunk: 2.2.0
  • ● remote-redux-devtools: 0.5.0
  • ● remote-redux-devtools-on-debugger: 0.8.0
  • ● babel-eslint: 7.2.3
  • eslint: 4.4.1
  • ● eslint-plugin-flowtype: 2.35.0
  • ● eslint-plugin-import: 2.7.0
  • ● eslint-plugin-jsx-a11y: 6.0.2
  • ● eslint-plugin-prettier: 2.1.2
  • ● eslint-plugin-react: 7.1.0
  • ● eslint-plugin-react-native: 3.0.1
  • ● flow-bin: 0.52.0
  • ● flow-typed: 2.1.5
  • ● husky: 0.14.3
  • ● jest: 20.0.4
  • ● jest-expo: 19.0.5
  • ● prettier: 1.5.3
  • ● react-native-scripts: 1.1.0
  • ● react-test-renderer: 16.0.0-alpha.12

BROUGHT TO YOU BY

Start building your app today!

Get Started