GIF React Native Taxi App Theme

React Native Taxi App Theme

The ideal starter kit / app script with all the needed UI elements alongwith Redux, NativeBase to build your iOS and Android Uber-for-X service app


6 Months Support

All the screens you want!

Fully customizable, ready-to-use screens for users, AND drivers along-with a rich collection of UI elements specifically for an ideal taxi booking / passenger app like Uber / Ola / Lyft

  • ● Set PickUp Location
  • ● User Profile
  • ● Notifications
  • ● Drawer menu
  • ● Select A Trip
  • ● Confirmation page
  • ● En Route
  • ● Start Trip
  • ● Payment (with options)
  • ● Credit card form
  • ● Register/ Sign In
  • ● Splash Screen
  • ● Complete Trip
  • ● Trip Overview With Rating
  • ● Next Stop & Upcoming Stops

React Native Taxi App Theme

NOTE

This starter kit is only a UI theme and it doesn't include any back-end code, neither it is wired up with any API calls.

Features

  • Power-packed with Redux, NativeBase
  • Integrated with CRNA and Expo
  • Single JavaScript code base for iOS & Android
  • Mass of theme specific UI elements, components
  • Fascinated blend of React Native and ES6
  • Easy Routing, just like web
React Native Taxi App Theme

Passenger View + Driver View

Fully customizable, ready-to-use screens for users and drivers along-with a rich collection of UI elements specifically for an ideal taxi booking / passenger app like Uber / Ola / Lyft

Package

React Native Taxi App Theme

  • ● lodash: ^4.13.1
  • ● moment: ^2.17.1
  • native-base: 2.1.0-rc.2
  • expo: ^15.1.0
  • ● react: ~15.4.0
  • react-native: 0.42.0
  • ● react-native-country-picker-modal: ^0.2.10
  • ● react-native-easy-grid: ^0.1.8
  • ● react-native-router-flux: ^3.38.0
  • ● react-redux: ^5.0.3
  • redux: ^3.6.0
  • ● redux-persist: ^4.4.2
  • ● redux-thunk: ^2.2.0
  • ● replace: 0.3.0
  • ● rx: ^4.1.0
  • ● react-native-scripts: 0.0.26
  • ● jest-expo: ^0.3.0
  • ● react-test-renderer: ~15.4.1
  • ● babel-jest: 16.0.0
  • ● babel-preset-react-native: 1.9.0
  • ● chai: ^3.5.0
  • ● jest: 16.0.2
  • ● jest-react-native: 16.0.0
  • ● mocha: ^2.5.3
  • ● remote-redux-devtools: ^0.3.3
  • ● remote-redux-devtools-on-debugger: ^0.4.6

BROUGHT TO YOU BY

Start building your app today!

Get Started